Troubleshooting MaxMind job failures

Parth Datwani  
Edited

MaxMind libraries can become outdated and no longer provide the latest insights, even if the pipeline was previously configured with a MaxMind license. The daily refresh job fails to run, preventing library updates.

Cause

Snowplow pipeline with MaxMind integration configured with a MaxMind license key.

Expired MaxMind license key causing the refresh job to fail with a 403 error response when attempting to retrieve library updates.

Resolution

Your MaxMind libraries can become outdated if the daily refresh job fails to run. If you've previously configured your pipeline with a MaxMind license and are no longer seeing the latest insights, the instructions below may help you.

Check License Expiry

The most common cause of MaxMind update failures is an expired license. When attempting to update the library, the endpoint will respond with a 403 error to indicate the license key is either incorrect or expired.

If you're a Snowplow customer, renew your license, then reach out to our friendly team so that we can update the credentials used by the refresh job.